云计算技术-HCIA之VLAN及总结

辉辉科技论坛管理员   ·   发表于 2020-5-16   ·   实用技术

云计算技术-HCIA之VLAN及总结

1、Windows下安装华为HCIA实验环境,首先得安装WinPcap、Wireshark、VirtualBox等软件,才能安装eNSP。——安装过程省略

注:补充

Windows下HCIA实验环境64位安装包下载地址:

链接:https://pan.baidu.com/s/1qWcO1QdVFPYTzKcORPNIcQ 提取码:jnf9

①WinPcap是windows平台下一个免费,公共的网络访问系统主要应用程序提供访问网络底层的能力。它提供了以下几种功能:1. 捕获原始数据包,包括在共享网络上各主机发送/接收的以及相互之间交换的数据包;2.在数据包发往应用程序之前,按照自定义的规则将某些特殊的数据包过滤掉3.在网络上发送原始的数据包4.收集网络通信过程中的统计信息

②Wireshark(前称Ethereal)是一个网络封包分析软件。网络封包分析软件的功能是撷取网络封包,并尽可能显示出最为详细的网络封包资料Wireshark使用WinPCAP作为接口,直接与网卡进行数据报文交换。

VirtualBox 是一款开源虚拟机软件

④eNSP(Enterprise Network Simulation Platform)是一款由华为提供的免费的、可扩展的、图形化操作的网络仿真工具平台,主要对企业网络路由器、交换机进行软件仿真,完美呈现真实设备实景,支持大型网络模拟,让广大用户有机会在没有真实设备的情况下能够模拟演练,学习网络技术。


1、实验题:

(1)PC1和PC3所在接口位Access且pvlanvlan2

(2)PC2/PC4/PC5/PC6处于同一网段,其中PC2可以访问PC4/PC5/PC6,但PC4可以访问PC5,不能访问PC6,PC5不能访问PC6;

(3)PC机子为DHCP自动获取IP地址。


方案:

根据实验题目要求可以将所有PC划为4个vlan,PC1/PC3为同一vlan2、PC2为vlan3、PC4/PC5为同一vlan4、PC6为vlan5。

路由器为PC2/PC4/PC5/PC6分配IP地址且为同一网段,网段为192.168.1.0/24.PC1/PC3获取IP为同一网段,网段为192.168.2.0/24.

 

 

答:

R1上的配置:

 $

system-view

#

dhcp enable

ip pool V1

[Huawei-ip-pool-V1]gateway-list 192.168.1.1

[Huawei-ip-pool-V1]network 192.168.1.0 mask 255.255.255.0

[Huawei-ip-pool-V1]dns-list 8.8.8.8 114.114.114.114

[Huawei-ip-pool-V1]quit

ip pool V2

[Huawei-ip-pool-V2]gateway-list 192.168.2.1

[Huawei-ip-pool-V2]network 192.168.2.0 mas

[Huawei-ip-pool-V2]network 192.168.2.0 mask 255.255.255.0

[Huawei-ip-pool-V2]dns-list 8.8.8.8 114.114.114.114

[Huawei-ip-pool-V2]quit

#

interface Ethernet 0/0/8

[Huawei-Ethernet0/0/8]ip address 192.168.1.1 255.255.255.0

[Huawei-Ethernet0/0/8]dhcp select global

[Huawei-Ethernet0/0/8]quit

#

interface Ethernet 0/0/8.1

[Huawei-Ethernet0/0/8.1]dot1q termination vid 2

[Huawei-Ethernet0/0/8.1]ip address 192.168.2.1 255.255.255.0

[Huawei-Ethernet0/0/8.1]arp broadcast enable

[Huawei-Ethernet0/0/8.1]dhcp select global

 

Switch1上的配置:

$

system-view

#

vlan batch 2 to 5

 

[Huawei]interface GigabitEthernet 0/0/1

[Huawei-GigabitEthernet0/0/1]port link-type access

[Huawei-GigabitEthernet0/0/1]port default vlan 2

[Huawei-GigabitEthernet0/0/1]quit

 

[Huawei]interface GigabitEthernet 0/0/2

[Huawei-GigabitEthernet0/0/2]port hybrid pvid vlan 3

[Huawei-GigabitEthernet0/0/2]port hybrid untagged vlan 3 to 5

[Huawei-GigabitEthernet0/0/2]quit

 

[Huawei]interface GigabitEthernet 0/0/23

[Huawei-GigabitEthernet0/0/23]port hybrid tagged vlan 2

[Huawei-GigabitEthernet0/0/23]port hybrid untagged vlan 3 to 5

[Huawei-GigabitEthernet0/0/23]quit

 

[Huawei]interface GigabitEthernet 0/0/24

[Huawei-GigabitEthernet0/0/24]port link-type trunk

[Huawei-GigabitEthernet0/0/24]port trunk allow-pass vlan 2 to 5

[Huawei-GigabitEthernet0/0/24]

 

Switch2上的配置:

<Huawei>system-view

[Huawei]vlan batch 2 to 5

[Huawei]interface GigabitEthernet 0/0/23

[Huawei-GigabitEthernet0/0/23]port link-type trunk

[Huawei-GigabitEthernet0/0/23]port trunk allow-pass vlan 2 to 5

[Huawei-GigabitEthernet0/0/23]quit

[Huawei]interface GigabitEthernet 0/0/1

[Huawei-GigabitEthernet0/0/1]port link-type access

[Huawei-GigabitEthernet0/0/1]port default vlan 2

[Huawei-GigabitEthernet0/0/1]quit

 

[Huawei]interface GigabitEthernet 0/0/2

[Huawei-GigabitEthernet0/0/2]port hybrid pvid vlan 4

[Huawei-GigabitEthernet0/0/2]port hybrid untagged vlan 3 to 4

[Huawei-GigabitEthernet0/0/2]quit

 

[Huawei]interface GigabitEthernet 0/0/24

[Huawei-GigabitEthernet0/0/24]port link-type trunk

[Huawei-GigabitEthernet0/0/24]port trunk  allow-pass vlan 2 to 5

 

Switch3上的配置:

<Huawei>system-view

 

[Huawei]vlan batch 2 to 5

 

[Huawei]interface GigabitEthernet 0/0/1

[Huawei-GigabitEthernet0/0/1]port hybrid pvid vlan 4

[Huawei-GigabitEthernet0/0/1]port hybrid untagged vlan 3 to 4

[Huawei-GigabitEthernet0/0/1]quit

 

[Huawei]interface GigabitEthernet 0/0/2

[Huawei-GigabitEthernet0/0/2]port hybrid pvid vlan 5

[Huawei-GigabitEthernet0/0/2]port hybrid untagged vlan 3 to 5

[Huawei-GigabitEthernet0/0/2]quit

 

[Huawei]interface GigabitEthernet 0/0/24

[Huawei-GigabitEthernet0/0/24]port link-type trunk  

[Huawei-GigabitEthernet0/0/24]port trunk allow-pass vlan 2 to 5



总结:

1、VLAN :虚拟局域网:将交换机的端口划分进特定的VLAN(不同的广播域)


2、为什么需要VLAN?因为整台交换机的所有端口均属于同一个广播域


3、一个VLAN中所有设备都是在同一广播域内,不同的VLAN为不同的广播域VLAN之间互相隔离,广播不能跨越VLAN传播,因此不同VLAN之间的设备一般无法互访,不同VLAN间需通过三层设备实现相互通信


4、一个VLAN一般为一个逻辑子网,由被配置为此VLAN成员的设备组成VLAN中成员多基于交换机的端口分配,划分VLAN就是对交换机的接口划分


5、VLAN工作于OSI参考模型的第二层VLAN是二层交换机的一个非常根本的工作机制


6、VLAN的范围


7、

思科配置思路:

1)交换机上创建vlan

2)接入划入vlan

3Trunk干道

4)Vlan间路由-路由器子接口  多层交换机svi

思科下交换机的接口只有接入和中继模式

华为vlan逻辑:

1)所有数据帧在一个交换机内部转发时,必须存在标签

2)在每一个交换机的接口上存在转发允许列表,只有被允许的流量才能通过该接口进或出

3)流量从一个接口出去时,可以继续携带标签或被剥离标签

华为交换机接口存在三个模式、接入、中继、混杂模式。




0 Reply   |  Until 2020-5-16 | 570 View
LoginCan Publish Content